MicroStation Quick Start Guide

MicroStation V8i (SELECTseries 2)
Trademark Notice

Bentley and the "B" Bentley logo are either registered or unregistered trademarks or service marks of Bentley Systems, Incorporated. All other marks are the property of their respective owners.

Copyright Notice

Copyright © 2010, Bentley Systems, Incorporated. All Rights Reserved.
# Table of Contents

**Welcome to MicroStation**                             1  
  Launching MicroStation                                1  
  Getting Oriented                                      3  
    View windows                                        4  
    Models                                              4  
    Menus                                               5  
    Tools and tool icons                                7

**Drawing and Viewing**                                 9  
  Placing Elements                                      9  
    Snapping for precision                              10  
  Working With Views                                    12  
  Saving Your Work                                      14  
  Getting Help                                          15

**Basic MicroStation Workflow**                          17  
  Using Tools and View Controls                         17  
    Default tool                                         17  
    Interrupting the selected tool to use a view control 17  
    Tool settings                                        20  
  Element Attributes                                     20  
  As Easy as 1-2-3 — 4                                   23  
    1. Set the active element attributes                  23  
    2. Select the tool                                    23  
    3. Adjust the tool settings                           24  
    4. Follow the status bar prompts                     24  
  Settings of Other Types                                26  
  Creating Printed Output and PDF Files                  29
Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manipulating and Modifying Elements</td>
<td>31</td>
</tr>
<tr>
<td>Manipulating Elements</td>
<td>31</td>
</tr>
<tr>
<td>Moving elements</td>
<td>31</td>
</tr>
<tr>
<td>Copying elements</td>
<td>33</td>
</tr>
<tr>
<td>Working with multiple elements</td>
<td>34</td>
</tr>
<tr>
<td>Rotating elements</td>
<td>35</td>
</tr>
<tr>
<td>Scaling elements</td>
<td>38</td>
</tr>
<tr>
<td>Modifying Elements</td>
<td>39</td>
</tr>
<tr>
<td>Deleting Elements</td>
<td>41</td>
</tr>
<tr>
<td>Placing Cells and Text</td>
<td>43</td>
</tr>
<tr>
<td>Placing Cells</td>
<td>43</td>
</tr>
<tr>
<td>Placing Text</td>
<td>45</td>
</tr>
<tr>
<td>Learning Paths</td>
<td>51</td>
</tr>
<tr>
<td>Professional Training from The Bentley Institute</td>
<td>51</td>
</tr>
<tr>
<td>OnDemand eLearning</td>
<td>52</td>
</tr>
<tr>
<td>Live training</td>
<td>52</td>
</tr>
<tr>
<td>The MicroStation learning path</td>
<td>52</td>
</tr>
<tr>
<td>Key Concepts and Tools</td>
<td>53</td>
</tr>
<tr>
<td>Design plane and working units</td>
<td>54</td>
</tr>
<tr>
<td>Levels</td>
<td>55</td>
</tr>
<tr>
<td>Seed files and DGN libraries</td>
<td>56</td>
</tr>
<tr>
<td>Workspaces</td>
<td>58</td>
</tr>
<tr>
<td>AccuDraw</td>
<td>59</td>
</tr>
<tr>
<td>Snap modes</td>
<td>60</td>
</tr>
<tr>
<td>Hatching and patterning</td>
<td>61</td>
</tr>
<tr>
<td>Measuring and dimensioning</td>
<td>62</td>
</tr>
<tr>
<td>Element templates</td>
<td>63</td>
</tr>
<tr>
<td>References</td>
<td>64</td>
</tr>
<tr>
<td>Saved views</td>
<td>65</td>
</tr>
<tr>
<td>Composing drawings</td>
<td>66</td>
</tr>
<tr>
<td>Link sets</td>
<td>68</td>
</tr>
<tr>
<td>3D modeling and visualization</td>
<td>69</td>
</tr>
<tr>
<td>Design history</td>
<td>70</td>
</tr>
<tr>
<td>ProjectWise</td>
<td>71</td>
</tr>
<tr>
<td>Index</td>
<td>73</td>
</tr>
</tbody>
</table>
Welcome to MicroStation

Launching MicroStation

You will begin by launching MicroStation and creating a MicroStation document file, called a design file.

There are several ways to launch MicroStation. Here you will use the most conventional way.

Exercise: Launch MicroStation

1. Click the Windows Start button.
2. Select All Programs > Bentley > MicroStation V8i (SELECTseries 2) > MicroStation V8i (SELECTseries 2).

MicroStation launches and the File Open dialog appears.

In the lower right corner, if User and Project are not set to untitled as shown, set them to untitled before continuing.

Eventually you may find that the easiest way to start your MicroStation session is to double-click the design file with which you want to work. The standard extension for design files is .dgn.
Exercise: Create and open a design file

1. Continuing in the File Open dialog, click the New file icon.

2. In the New dialog, type the file name Quick Start.

   There is no need to type the extension .dgn because it will be automatically appended for you.

3. Click Save.

   Back in the File Open dialog, your new file, Quick Start.dgn, is selected.

4. Click Open.

   The file opens and you are presented with the default MicroStation application window interface. The title bar displays the name of the open file.
Getting Oriented

The first time you see the MicroStation application window, you may feel a little overwhelmed. You need not be. Here we highlight the features most relevant for a quick start.
Getting Oriented

View windows

View windows are for working on drawings. You should now see two view windows, View 1 and View 2. View 2 is mostly covered by View 1.

MicroStation allows you to open as many as eight views. The title bar of the active view is highlighted.

➔ Exercise: Open and close views

1. Continuing in Quick Start.dgn, select Window > Views > 3 from the main menu bar at the top of the application window.
   This opens a third view window, View 3.
   You can also open view windows using the numbered buttons in the View Groups dialog, which is at the lower left of the application window.

   2. Click the 8 button.
      This opens View 8.

   3. Click the 3 and 8 buttons to close those views.

   Note: Closing all the view windows is not the same as closing the file.

What are the dots and orthogonal lines?

The dots and lines in View 1 comprise the grid, a drawing aid. Later you will use it in an exercise. Its use is optional, as is its display.

Models

In the title bar of View 1, note the word “Default” to the right of the view number. This indicates View 1 displays the model “Default”. A model is a separate working, graphical space within a design file.

Design files can contain multiple models. They are equivalent to worksheets in Excel. Think of a model as a separate design within a design file.

Every newly created design file contains a model named Default. You can change its name and description.
Menus

The application window contains the main menu bar.

Some dialogs have menu bars as well. The exercises in this guide will use a few of the most frequently used menu items.

One menu item you should learn about is *Edit > Undo*. This is the “fix my mistake” command, critical to using MicroStation and just about any other application you ever use.

- Adjacent to the word “Undo” in the menu you will see a description of the effect of selecting Undo at that moment, for example, Undo Place Line
- You can undo multiple steps by selecting Undo multiple times
- The keyboard shortcut for selecting Undo is Ctrl + Z

Contextual menus

MicroStation also has pop-up, contextual (right-click) menus. These menus contain items that operate on the control or object at the pointer location.

The first time you click the right mouse button, MicroStation asks you whether you want to access the contextual menus by pressing and holding the button or by clicking it.
Exercise: Set the preference for the right mouse button

1. Click the right mouse button.
   If this is the first time you have right-clicked in MicroStation, this will open a special one-time dialog.

2. Click OK to accept the default, Click for Reset.

Note: If in this dialog you previously selected the Click option, do the following:
   - Select Workspace > Preferences.
   - In the Preferences dialog, select the category Input.
   - In the Reset Pop-up Menu drop-down menu, select Press and Hold.
   - Click OK.
Tools and tool icons

Docked to the left edge of the application window are groupings of icons. Each of these icons represents a MicroStation drawing tool.

As is typical for graphics applications, MicroStation is tool-driven. Should you want to draw a circle, for example, you would use the Place Circle tool. To activate that tool, you would click its icon, which, as you would expect, is a circle.

When you read in this guide, for example, “select the Place Circle tool,” the literal meaning is “activate the Place Circle tool by clicking its icon.”

With these few critical preliminaries out of the way, you will next begin hands-on learning.
Placing Elements

The objects one draws, or places, in a model, lines, polygons, arcs, circles, ellipses, text, etc., are elements. The first element placement tool you will use is Place Circle.

⇒ Exercise: Placing a circle

1. Continuing in Quick Start.dgn, select the Place Circle tool from the tools docked along the left side of the application window.

    ![Place Circle tool](image)

    The status bar at the bottom of the application window displays the name of the selected tool, Place Circle, the placement method, By Center, and prompts you to “Identify center point.”

2. Click in the left half of View 1 and drag in any direction. A circle will display dynamically. When the circle is the desired size, stop dragging and release the mouse button.
What did your actions instruct MicroStation to do?

- When you started dragging, you positioned the center of the circle.
- When you stopped dragging, you positioned the edge of the circle.

These two locations are called data points.

While dragging to enter data points is fast and easy for sketching, if precision is required, the preferred technique is clicking to enter each data point. Try it. The Place Circle tool is still active, so you can start by immediately entering the data points.

**Exercise: Placing a circle by clicking to enter the data points**

1. Enter a data point to the right of the first circle to define the center of the new circle. That is, position the pointer where you want the circle to be centered, and then click the left mouse button.

2. Move the pointer away from the center and see that the circle is dynamically displayed as it was when you dragged.

3. Enter a data point outside the first circle to define the edge of the new circle.

Because the left mouse button is used in MicroStation to graphically enter data points, it is called the Data button. The right mouse button is called the Reset button. Its use will be illustrated in the next exercise.

**Snapping for precision**

MicroStation has the precision essential for engineering projects. The next exercise will demonstrate AccuSnap, which helps you enter data points at precise locations on existing elements.
Exercise: Placing a line connecting two circles

1. Select the Place SmartLine tool.

   ![SmartLine tool icon]

   This tool can be used to place lines, arcs, line strings with connected segments, and even polygons.

2. Move the pointer to the circle to the left near its three o’clock position.

   The circle highlights and an “x” appears to mark three o’clock.

   ![Circle with an “x” at three o’clock]

   You are seeing AccuSnap at work.

3. While the “x” is displayed, click the Data button.

   The data point snaps to three o’clock regardless of the exact pointer location.

4. Move the pointer horizontally to the other circle.

   The line is dynamically displayed as you move the pointer. As the pointer nears the other circle, the circle highlights and an “x” marks nine o’clock. If the line appears jagged because the circles are not horizontally aligned, this is okay.

   ![Line connecting two circles with an “x” at nine o’clock]
5 Snap a data point to nine o’clock.

The Place SmartLine tool dynamically displays a new segment of what would become a line string were you to continue. (If you are not satisfied with the location of this data point, use Undo.)

6 Reset — click the Reset (right mouse) button.

This tells MicroStation you are done placing this element.

You use a reset to

- End an operation
- Back up a step during an operation
- To reject the highlighted element and consider another during element manipulation and modification operations

---

**Working With Views**

Tools that operate on views are called view controls to distinguish them from drawing tools. The view control icons are in the view control bar, the toolbox at the top of each view window.

In a moment we will illustrate how to use some view controls. First, though, you will try out a pair of useful alternative methods of view control, zooming and dynamic panning.

**Note:** These methods require the use of a mouse wheel. If you do not have a scrolling mouse, skip the next two exercises.

**⇒ Exercise: Zooming in and out**

1 Continuing in Quick Start.dgn, position the pointer in View 1.
2 Roll the mouse wheel backward.
   This zooms the view out and the degree of magnification decreases.

3 Roll the mouse wheel forward.
   This zooms the view in.

➤ **Exercise: Dynamically panning**

1 Continuing in Quick Start.dgn, position the pointer in View 1.

2 Press the mouse wheel button and move the mouse.

You can combine these techniques to seamlessly switch between zooming and panning. This takes some practice, though. You may at times zoom in too close, zoom out too far, or dynamically pan too far in a certain direction and as a result, find yourself lost.

The Fit View, View Previous, and View Next view controls can help you recover from this situation.

➤ **Exercise: Fitting a view**

1 Continuing in Quick Start.dgn, in View 1’s view controls, select Fit View.

   ![Fit View button]

   Now you can see all the elements in the model.

   Fit View is still active. You can apply it to any or all open views without reselecting it.

2 Enter a data point in View 2 to select that view as the target for a fit operation.

3 Verify View 2 is now also a fitted view: Click its title bar to bring it to the front, thereby making it the active view.

It is a good idea to practice with view controls for two or three minutes at the beginning of a new session for your first few days using MicroStation.

View Previous and View Next are used to undo and redo view control operations.

➤ **Exercise: Using View Previous/View Next**

1 Continuing in Quick Start.dgn, make View 1 the active view by clicking its bottom border.

2 In View 1’s view controls, select View Previous.
Saving Your Work

MicroStation is unusual in its approach to saving. By default MicroStation automatically saves in the design file all changes to the active model — element placements, manipulations, modifications, and deletions — as you make them.

However, MicroStation does not automatically save settings, including the view configuration. You can manually save settings.

⇒ Exercise: Saving settings

1. Continuing in Quick Start.dgn, select File > C:\Documents and ... Quick Start.dgn, in the history section of the File menu just above Exit.

   This closes and reopens the file. When the file reopens, View 1 is no longer a fitted view. Because you did not save settings, View 1 displays the same area as the last time you opened the file.

2. Fit View 1.

3. Select File > Save Settings (or, press Ctrl + F, the shortcut).

   The prompt in the status bar reads “Settings Saved”.

4. Close and reopen the file again.

   When the file reopens, View 1 is fitted. In fact, all aspects of the view configuration, including view status (open/closed), size, position, and content, are restored.

Note: You can optionally set a preference (select Workspace > Preferences, then the Operation category) to automatically save settings as you apply changes.
Getting Help

Select Help > Contents to open the MicroStation help document. You can browse topics, use the index, and perform keyword searches.

Help is context-sensitive: Pressing <F1> will open the help document directly to the topic related to your current task.

You can optionally turn on the help Tracking feature to automatically display help for each newly selected tool.

**Exercise: Using help tracking**

1. Continuing in Quick Start.dgn, select Help > Tracking from the main menu bar.
2. Select Help > Contents to open the help document.
   The help window displays the table of contents.
3. Select the Place Circle tool.
   The help window displays the relevant topic.
4. Select Place SmartLine.
   Help continues to track your tool selection.
5. In the help window’s toolbar, select Home.
   This returns to the table of contents.
6. Turn off Help > Tracking.
Basic MicroStation Workflow

Using Tools and View Controls

Thus far you have been introduced to two MicroStation drawing tools, Place Circle and Place SmartLine, plus some view controls. Shortly we will cover tool settings and the interplay between drawing tools and view controls.

First, though, you will be introduced to the simple, yet fundamental, concept of the default tool.

Default tool

One tool or another is selected, or active, at all times. The default selected tool is Element Selection, which is used to select elements for manipulation or modification. Element Selection is automatically selected when you open a design file.

Interrupting the selected tool to use a view control

As you use tools, you will sometimes have a need to interrupt your drawing operation to adjust the view contents. MicroStation helps you handle this situation efficiently as you will see here while you place a square in one of your circles.
Exercise: Interrupting the Place Block tool to use the Window Area view control

1. Continuing in Quick Start.dgn with View 1 as a fitted view, select the Place Block tool.

   ![Place Block tool](image)

   This tool is used to place rectangles, including squares.

2. Snap a data point on the circle to the left midway between the nine o’clock and twelve o’clock positions. AccuSnap will help you by highlighting the circle when the pointer is near that midway keypoint.

3. Move the pointer down and to the right.

   The status bar prompt reads “Enter opposite corner.” You will let AccuSnap help you do that, but first you will get a better view of AccuSnap in action. While you could zoom in, here you will try out another view control, one that lets you define the area of the view by specifying corner points.

4. In View 1’s view controls, select Window Area.

   The status bar reads “Window Area > Define first corner point”.

5. Enter a data point at or near the center of the circle.

   ![Window Area control](image)

   The prompt now reads “Define opposite corner point”.


6 Enter a data point to define the opposite corner point below and to the right of the circle.

7 Reset (click the Reset, right, mouse button).

The reset returns you to Place Block. The square is once again dynamically displayed, and the prompt reads as it did immediately before you selected Window Area.

8 With the help of AccuSnap, snap to the circle midway between the three o’clock and six o’clock positions and enter a data point.

9 Zoom Out to see the entire square.

As you have seen, a reset will return you to the previously selected tool from a view control.
Tool settings

You may have noticed a floating dialog whose title and contents change each time you select a tool or view control. This dialog is the tool settings window.

Almost every MicroStation tool has settings. The tool settings window lets you adjust the settings of the currently selected tool.

Some tools have multiple purposes and for those a setting specifies the purpose for a given single use. For example, Place Block can be used to place orthogonal and rotated blocks. The Method drop-down menu in the Place Block settings lets you choose between the two.

Ordinarily upon selecting a tool you will adjust its settings before entering any data points. However, some tool settings are not applicable until data points are entered.

For example, while you use Place SmartLine, after you enter three or more data points and then move the pointer near the location of the first data point, a check box labeled Closed Element will appear in the tool settings window, enabling you to place a polygon.

Element Attributes

All of the elements you have placed look the same. For one, they are all white in color. Color is an element attribute.

- The active color is the design file setting that determines the color of elements when placed.
- The active color was white when you placed those elements — and it still is.
There are several element attributes:

- color
- line style
- line weight
- transparency
- priority
- level
- fill type (applies only to closed elements, such as circles and shapes)
- fill color (applies only to closed elements)

Each of the above attributes has an active setting, for example, the active line weight.

Level fundamentally differs from the other attributes. Think of a level as a transparent overlay. Levels can be displayed or hidden on a view by view basis. If, for example, you were to turn off the display of the level named Doors in View 3, all elements in View 3 residing on that level would not be visible in that view.

**Note:** If you are at a site with experienced MicroStation users, the administrator will likely have implemented a logical level structure that facilitates the design workflow. The level structure may specify level symbology (level-specific color, line style, and line weight) so the appearance of elements is determined by their level. Make sure you know the standards for level usage for projects to which you are assigned.

**Exercise:** Setting active attributes for element placement

1. Continuing in Quick Start.dgn, locate the Attributes toolbox near the upper left corner of the application window, just below the File menu.

2. Select the Active Level drop-down menu. Note that the design file has only one level, Default.
Element Attributes

3  In the Active Color drop-down menu, select yellow, color value 4.

4  In the Active Line Style drop-down menu, select 5, a dashed line style.

5  In the Active Line Weight drop-down menu, select 8, a line weight with moderate thickness.

6  Use Place Block with AccuSnap to place a square in the circle to the right.
7. Compare the appearance of the new square with the one in the circle to the left.

As Easy as 1-2-3 — 4

You have learned about data points and resets, tool settings, and element attributes. Now put all this knowledge together to summarize the basic MicroStation workflow.

1. Set the active element attributes

Although you can change the attributes of an element after you place it, it is advisable to check, and, if necessary, adjust the active element attribute settings first.

Skip this step if you are not placing an element or you are about to use a tool that does not rely on element attributes.

2. Select the tool

All MicroStation tools and the toolboxes in which they reside are accessible through the Tools menu. As you continue to learn, experiment with different tools and use Undo as needed.
3. Adjust the tool settings

The help document contains descriptions of all tool settings. To open the help document to the topic relevant to the selected tool, click in the tool settings window and press <F1>.

![Tool Settings](image1)

4. Follow the status bar prompts

The prompts in the status bar tell you how to proceed from step to step.

![Prompt](image2)

You will know you are mastering a tool when you no longer need to read the prompts.

This next exercise, in which you will be introduced to the Place Arc tool, takes you through all four steps. Continuing in Quick Start.dgn, you will apply yellow highlighting to the right half of the edge of the circle to the right.

- First identify the center of the arc, which will be at the center of the circle.
- Draw the arc starting at the top of the circle.

→ Exercise: Placing an arc

1. **Set active element attributes:** In the Attributes toolbox, in the Active Line Style drop-down menu, select 0 (solid).

![Attributes Toolbox](image3)

2. **Select the tool:** Place Arc

![Place Arc Tool](image4)
3  *Adjust the tool settings:*

- In the tool settings, change the default Method — Start, Center — to Center, Start.
- Then change the default Direction — CCW (counterclockwise) — to CW (clockwise).

4  *Follow the prompts:*

- “Identify center point” — snap a data point to the center of the circle to the right.
- “Identify start of arc” — snap a data point to the top of the circle.
- “Define arc sweep angle” — move the pointer in the clockwise direction to the bottom of the circle and snap a data point there.
Settings of Other Types

You have learned about tool settings, the view configuration, and the active element attribute settings. You have also learned about using File > Save Settings.

There are numerous other types of settings in MicroStation, including

- Element-specific active attribute settings such as those specific to dimension or text elements
- Working units and other design file settings
- Level definitions
- View attributes and level display settings
- Configuration variables
- User preferences

To delve deeply into these would take us beyond the realm of a quick start. As you receive training and gain experience, you will learn which settings are most important to your projects.

As an introduction, you will in the next series of exercises use the grid to place a rectangular border in your model and adjust settings that control the effect of the grid and its display.

→ Exercise: Controlling grid display

1. Continuing in Quick Start.dgn, in View 1’s view controls, click the downward pointing arrow to the right of the View Attributes icon.
The View Attributes dialog appears.

2. In the Presentation section, click the Grid icon.
   This turns off the display of the grid in View 1.
3. Click the icon again to turn the grid display back on.
4. Move the pointer away from the dialog.
   The dialog disappears.

Thus far, you have not used the grid as a drawing aid — as you have entered data points, the presence of the grid has not had an effect. Its effect is determined by a design file setting, Grid Lock.

Exercise: Placing a rectangular border aligned to the grid

1. Continuing in Quick Start.dgn, turn on Settings > Locks > Grid.
   This turns on Grid Lock.
2. In the Attributes toolbox, set the active color to blue (color value 1), the active line style to 4, and the active line weight to 0.
3. Use the Window Area view control to window an area containing only the circle to the left.
4. Select the Place Block tool.
5 Position the pointer above and to the left of the circle but not on a grid point.

6 Click the Data button.

Because Grid Lock is on, MicroStation positions the new data point not at the location of the pointer but instead on the closest grid point. Grid Lock locks newly entered data points to the grid. Its effect will be more apparent in the next step.

7 Move the pointer down and to the right and notice how the lower right corner of the dynamically displayed border jumps from one grid point to the next.

8 Pan to the area below and to the right of the other circle, and position the pointer there.

9 Enter a data point to define the opposite corner of the border and place the border.
10 Fit View 1 to see the model with its new border.

Note: As you become more experienced, you will likely find other drawing aids, such as AccuSnap, which you have already used, and AccuDraw, to be more useful than the grid.

Creating Printed Output and PDF Files

The steps to create a print, or PDF file, from MicroStation are as follows:

1 Open the Print dialog.
2 Define the print area.
3 Select a printer driver, either the Windows driver or a Bentley driver.
   The Windows driver works best with typical desktop printers. Bentley drivers are provided for use with plotters and for creating PDF files.
4 Set printing parameters, such as sheet size and scale.
5 Preview the print.
6 Click the Print icon to create output.

Setting printing parameters is the most difficult and time consuming part of the process and this guide does not cover the details. Setting the print scale can be particularly challenging. A printer's units and design file working units are not always the same.

Because you may not have an accessible printer, you will create a PDF of the active model.
Exercise: Creating a PDF

1. Continuing in Quick Start.dgn with View 1 as a fitted view, select File > Print (or, press Ctrl + P, the shortcut).

   The Print dialog appears. It contains a preview image of the output.

2. Under Printer and Paper Size, click the magnifying glass icon.

3. In the Select Printer Driver Configuration File dialog, select the Bentley printer driver configuration file that is used to generate PDF output, pdf.pltcfg, and click Open.

   In the Print dialog, note that the Windows driver option menu selection has changed to Bentley driver.

4. Set the following under Printer and Paper Size:

   *Paper*: ISO A3

   *Orientation*: Landscape

5. Click the Print icon.

6. In the Save Print As dialog, navigate to a location you will remember, and edit the File name field to read Quick Start.pdf. Then click Save.

   The PDF is created.

7. If Adobe Reader is installed on your system, open the PDF.

8. In MicroStation select File > Close to return to the File Open dialog.
Manipulating and Modifying Elements

Existing elements often need to be modified. You may need to move or copy them, or you may need to change their proportions. MicroStation has many tools to help you manipulate and modify elements.

Manipulating Elements

The tools in the Manipulate toolbox are used to manipulate entire elements.

Moving elements

The Move tool is used to move elements from one location to another. After you select the tool, you use one data point to select the element, and a second to identify the new location.

➔ Exercise: Moving an element

1. Continuing in the File Open dialog, set the following in the lower right corner by clicking the arrows next to the options:

   *User*: examples
   
   *Project*: General

![User and Project options]

This puts you into a workspace, which is a custom configuration that is set up by an administrator. By selecting a workspace, you customize MicroStation for a specific purpose, seeing things you need and not those...
you don’t. MicroStation is delivered with sample workspaces, and the General project is one of these.

2 Select the file Learning.dgn.

3 Click Open.

4 Select File > Models, or select the Models tool in the Primary Tools toolbox at the top of the MicroStation application window.

The Models dialog appears. It lists all of the models that are contained in this design file.

5 Double-click the model named Move and Copy.

You see the geometry that’s in the model. Now you will select a manipulation tool so you can move elements.

6 In the Main toolbox, near the top left of the application window, click the third tool, Copy, and continue to press on it.

A pop-up menu containing a list of tools opens. You can select tools from the list or open a toolbox containing all of them.

7 Move the pointer down and click Open ‘Manipulate’ as Toolbox.

You now see all the tools. You can move this toolbox around the screen or dock it.

8 Select the second tool, Move.

Since you have not placed a fence, a grouping device, there are no tool settings to set now. The status bar prompts you to identify the element you want to move.

9 In the middle row of elements, move the pointer over the center of the (red) circle in the second column so it highlights and you see an “x” in the center.
10 With the help of AccuSnap, snap to the center of the circle and enter a data point.

The circle is now attached to the pointer and the status bar prompts you to enter a data point where you want to place the circle.

11 Move the pointer to the approximate center of the block, and then enter a data point to place the circle.

Copying elements

The Copy tool requires one data point to select the element and a second one to define both the distance and direction to copy. The Copies option in the tool settings lets you specify how many copies to make. Using this method, one data point will result in multiple copies. The following exercises show you how to copy both ways.

→ Exercise: Copying an element

1 Continuing in Learning.dgn, in the Move and Copy model, select the first tool in the Manipulate toolbox, Copy.

2 Snap to the center of the circle you just moved and enter a data point. A copy of the circle is dynamically displayed at the pointer location.
3 Snap to one of the block’s corners and enter a data point.

The circle is copied to that corner, and a new copy is dynamically displayed at the pointer location.

4 Snap to each of the other three corners, entering data points, to place copies there.

5 Reset to end the operation.

Suppose you want to make multiple copies of these elements. In order to do that, you must group the block and circles. You will use the Element Selection tool to do this.

**Working with multiple elements**

► **Exercise: Make multiple copies of the elements**

1 Continuing in Learning.dgn, in the Move and Copy model, click the first tool in the Main toolbox, Element Selection.

2 Drag a rectangle around the elements.

   They are highlighted, or, selected.

3 Select the Copy tool and, in the tool settings, type 2 into the Copies field.

   The status bar prompts you to enter the first point.

4 Enter a data point on the selected elements.

   This identifies where you want to “pick up” the elements.

   Now the status bar prompts you to define where you want the copies.
5 Enter another data point to the right of the originals.

Two copies are created. When you create multiple copies like this, they are spaced using the distance from the original element to the data point. They are placed in the direction in which the data point is entered.

6 Reset to end the Copy operation.

The Element Selection is automatically reselected. It is the default selected tool.

7 In the tool settings, click Clear to deselect the elements.

Several of the manipulation tools have the option to make copies. So, if you want to rotate or scale an element and create copies at the same time, just check the check box and type in the number of copies.

Rotating elements

The Rotate tool rotates one or more elements based upon options set in the tool settings. For example, elements can be rotated about an active angle that you select or type in, or rotated dynamically by two or three points.

Exercise: Rotating an element

1 Continuing in Learning.dgn, select File > Models, or click the Models tool in the Primary Tools toolbox.

2 In the Models dialog, double-click the model named Rotate.

3 In the Manipulate toolbox, select the fourth tool, Rotate.
4 Set the following tool settings:

*Method:* 2 points

The status bar prompts you to identify the element you want to rotate. Note the elements in the top row. The annotation on the left shows you a good point around which to pivot the element.

5 Enter a data point on the element SIK7, top row, second column, so it highlights.

6 Snap to the pivot point on the highlighted element and enter a data point.

As you move the pointer, the element rotates dynamically.

7 Snap to the right end of the guide line on which the pivot point rests and enter a data point.

You can use the Element Selection tool to select elements meeting search criteria based on their attributes. Let’s use another selection method and another rotation method together.

**Exercise: Select elements and rotate by angle**

1 Continuing in Learning.dgn, in the Rotate model, select the Element Selection tool.

2 In the tool settings, click the Show Extended Settings arrow at the lower right.
    You see a series of tabs.
3 Select the Color tab.

You want to select the blades of the windmills whose color is yellow, or 4, in the current color table.

4 In the tool settings, scroll to the list entry for color number 4 and select it.

The yellow windmill blades highlight. In the left column, you can see that it is 45 degrees between the current blade location and the horizontal base. Since you know the required angle, you can use it.

5 Select the Rotate tool and set the following tool settings:

   Method: Active Angle

   In the field below, type: 45 and press Tab

6 Move the pointer.

   The blades are rotated, but they have moved away from the bases.

   To keep an element you are working with relative to another element you can use the About Element Center option when it appears in a tool’s settings.
7 In the tool settings, turn on About Element Center.
   The view updates to show the pending result of the operation.

8 Enter a data point to accept the rotation.
9 Reset to end the operation.

10 In the Element Selection tool settings, click Clear to deselect the elements.

Note: The blades on the left did not rotate because they are locked in place to facilitate the matching exercise.

Scaling elements

The Scale tool scales selected elements by an active scale value, or interactively when you enter data points. You can make a copy of the original element during the process. You can scale an element around its center point or a specified base point.

→ Exercise: Scaling an element

1 Continuing in Learning.dgn, open the model named Scale.
2 Using Element Selection, select the trees in the second row, second column.
3. In the Manipulate toolbox, select the third tool, Scale.

![Scale tool](image)

Above the trees you can see that the necessary scale is 2, so you can use the Active Scale option.

Think about the previous exercise and which other tool settings you need to use to make the trees on the right look like those on the left.

4. Set the following tool settings:

   - **Method**: Active Scale
   - **X Scale**: 2
   - **Y Scale**: 2
   - **About Element Center**: on

5. Enter a data point.

6. Reset.

7. In the Element Selection tool settings, click Clear to deselect the elements.

There is a padlock icon to the right of the X Scale and Y Scale fields in the tool settings. If the padlock is unlocked, or open, you can adjust the X Scale and Y Scale factors independently of each other. When the padlock is locked, or closed, adjusting one scale value will adjust the other when you press Tab. The padlock can be locked and unlocked by clicking on it. Many tools have this option.

---

### Modifying Elements

The Modify Element tool is an all-purpose modification tool that is used to change the spatial coordinates of an element’s geometry. With this tool, you can do the following.

- Move the end of a line
- Modify rounded segments of elements
- Scale an arc while maintaining its sweep angle
- Scale a block about the opposite vertex
- Change a circle's radius
**Exercise: Modifying an element**

1. Continuing in Learning.dgn, open the model named Modify.
2. In the Main toolbox, click the seventh tool, Modify Element, and continue to press on it.

3. Move the pointer down the pop-up menu and click Open ‘Modify’ as Toolbox.
4. Select the first tool, Modify Element.
   
   There are no tool settings yet. Once you identify an element for modification, you will see tool settings appropriate for that element.

5. Snap to the top left vertex of the outer element, enter a data point, and then observe the tool settings.

   ![Image of tool settings](image)

   You are preparing to round the vertex so that it remains orthogonal, at right angles to the original. In the left column you can see that the necessary rounding radius is 16.

6. Set the following tool settings:
   
   * **Vertex Type**: Rounded
   
   * **Rounding Radius**: 16

   As you move the pointer, the modified element is dynamically displayed.

7. Snap to the top left vertex of the outer element and enter a data point.
   
   The vertex becomes rounded.

8. Round the right vertex of the outer element using the same method.
9 Round the vertices of the inner element using the same method and a rounding radius of 8.

Deleting Elements

It is easy to delete entire elements. Use the Delete Element tool in the Main toolbox. You can either

- Select the elements to delete with Element Selection and then select Delete Element

or

- Select Delete Element first and then enter a data point on each of the elements

With the Element Selection method, you can press the Delete key on the keyboard instead of selecting Delete Element.

There are tools that are used to delete parts of elements. One such tool is Partial Delete, also known as Delete Part of Element. Its operation varies depending upon the type of element selected.

- With open elements, the first data point identifies both the element and start point for the partial delete. The second data point identifies the end of the partial delete.
- With closed elements, the first data point identifies the element and start of the partial delete, while the second establishes the direction and end point of the partial delete.

→ Exercise: Deleting parts of elements

1 Continuing in Learning.dgn, open the model named Partial Delete.

2 In the Modify toolbox, select the second tool, Partial Delete.

3 Use the tool to partially delete the elements in the right column. Do not worry about measurements for now, just use the tool.
Deleting Elements
Placing Cells and Text

Collections of elements that represent symbols or parts of a design can be permanently grouped and stored for reuse. Annotations make models easier to understand.

Placing Cells

In MicroStation, a group of elements that represents a symbol or part of a design is called a cell. Cells are complex elements that group multiple elements permanently. You can then place them in models without recreating the cell each time.

A specific series of steps is required to use cells. First you must attach the cell library in which the cells are saved, and then you can place the available cells.

➔ Exercise: Attaching a cell library

1. Continuing in Learning.dgn, open the model named Work with Existing Elements.
2. Select Element > Cells.
   This opens the Cell Library dialog which is used to attach cell libraries and make cells active for placement.
3. In the Cell Library dialog’s File menu, select Attach File.
4. In the Attach Cell Library dialog, navigate to the \Bentley\MicroStation V8i (SELECTseries)\WorkSpace\System\cell folder.
5. Select remodel.cel, and then click Open.
   The cells in remodel.cel are listed in the Cell Library dialog. You can place any of these cells using tools in the Cells toolbox.
Exercise: Placing cells

1. Continuing in Learning.dgn, in the Work with Existing Elements model, Zoom In on the office at the upper left.

2. In the Cell Library dialog, select the cell named DESK. Note the preview image in the box adjacent to the list of cells.

3. Click the Placement button. This makes the selected cell active for placement.


5. Select the Place Active Cell tool.

   The DESK cell is already specified in the tool settings as the Active Cell.

6. Set the following tool settings:

   * Active Angle: 0
   * X and Y Scale: 0.005

7. Enter a data point in the office to place the cell.

8. In the tool settings, click the magnifying glass icon next to the Active Cell field.

   This reopens the Cell Library dialog.

9. Select the CHAIR2 cell, and then click the Placement button.

11 Place a chair at the desk.

12 In the tool settings, change the Active Angle to 90 and place a chair on the right side of the desk.

13 Place a chair, at the correct angle, on the left side of the desk.

14 Reset.

Placing Text

MicroStation has a variety of tools with which you can annotate the geometry in your models. As an element, text is unique in that it has two distinct sets of attributes. There are element attributes, such as color, and text attributes, such as font and justification. The active text attributes are tool settings for the text placement tools.

Justification for single-line text (above) and multi-line text (below). From left: Left Top, Center, and Right Bottom.
The tools for working with text are in the Text toolbox.

→ **Exercise: Placing text**


   ![Text toolbox](image)

   The Text Editor window appears.

2. Set the following tool settings:
   - **Method**: By Origin
   - **Text Style**: Arial Bold
   - **Active Angle**: 0
   - **Height and Width**: 0.4
   - **Justification**: Center Center

3. In the Text Editor window, type the following:
   - Desk
   When you move the pointer, you can see that the text string is attached at its center.

4. In the tool settings, change the Justification to Left Bottom.
   Now the text string is attached to the pointer at that location.

5. Enter a data point on the desk to place the text.

6. Reset.
   The text clears from the Text Editor.

7. In the tool settings, change the Active Angle to 90, type the word Chair into the Text Editor, and then label the chair on the left side of the desk.
8 Change the Active Angle and label the other chairs.

If you do not reset, the text remains in the Text Editor, ready for placement.

![Diagram showing chairs and text]

9 Reset when you are done.

➔ Placing text above an element

1 Continuing in Learning.dgn, in the Work with Existing Elements model, with Place Text selected, type the word Wall into the Text Editor:

2 Change the following tool settings.

   * **Method**: Above Element
   * **Active Angle**: 0
   * **Justification**: Center Top

   This time the text is not attached to the pointer.

3 Enter a data point on the line element that represents the wall separating the upper and lower offices.

   The wall and the pending placement of the text are highlighted

![Diagram showing a wall and pending text placement]

4 Enter a data point to accept the placement.

   The text is placed right on the wall.

   That looks unprofessional so you will undo and try again. For this next attempt, you will adjust Line Spacing in the tool settings to create some space between the text and the wall.

5 Select **Edit > Undo**, or press Ctrl + Z.

6 In the tool settings, change Line Spacing to 0.5.
7. Enter a data point on the wall.
That looks better.

8. Enter a data point to accept the placement.

You can use the Fitted placement method to fit text into a space.

**Exercise: Fitting text**

1. Continuing in Learning.dgn, in the Work with Existing Elements model, with Place Text selected, type the word Insulation into the Text Editor.

2. Also in the Text Editor, click the I icon so that the text will be italicized.

   ![Insulation text]

   You can change font, bold, italics, and underline text attributes in the Text Editor.

3. Change the following tool settings:
   
   * **Method:** Fitted
   * **Justification:** Center Center

   The Active Angle, Height, and Width controls in the tool settings are now unavailable.

4. Enter a data point between the walls on the right side of the office.

5. Move the pointer in the downward direction.
   
The text is dynamically displayed.
6 When the text fits between the walls, enter a data point to place it.

7 Reset.

8 Select *File > Close*.
You have finished the exercises in this guide! Congratulations on making it to this point.

Are you ready to begin working on projects with MicroStation? Probably not. This guide covers only a small subset of MicroStation concepts and tools, and the examples are rather simplistic.

The information provided in this chapter will help you decide how to proceed:

- You will learn about paths you can take toward productivity with MicroStation
- You will be introduced to additional concepts and tools that are likely to be critical to your understanding and productivity

**Professional Training from The Bentley Institute**

The Bentley Institute offers professional training for users who want to master MicroStation and other Bentley software products. It is a global learning community that educates and sustains current and future generations of infrastructure professionals.

The following types of training are offered by the Bentley Institute:

- OnDemand eLearning
- LIVE training
OnDemand eLearning

OnDemand eLearning delivery options include:

- more than 1,100 video lectures
- hands-on courses totaling more than 7,300 hours of learning

LIVE training

Live hands-on training is delivered by Bentley experts in regularly scheduled courses. Delivery options include:

- Virtual classroom — improve your skills online while eliminating training-related travel time and cost
- Local classroom — receive instruction in a traditional classroom setting

The MicroStation learning path

The MicroStation learning path is the Bentley Institute’s recommended progression of professional development for infrastructure professionals who use MicroStation products. Browse to http://www.bentley.com/LearningPaths and follow the link to the MicroStation learning path.

From there you can follow links to register for course offerings.

Your first step along the MicroStation learning path will be either the MicroStation Essentials course or the MicroStation for AutoCAD Users course.

MicroStation Essentials

Designed for a new MicroStation user without previous CAD experience, this course teaches the concepts, tools, and features of the MicroStation drawing environment.
By implementing a typical workflow, students learn to create a drawing, plot, and solve real-world design problems from across the various engineering disciplines.

**MicroStation for AutoCAD Users**

Designed for an experienced AutoCAD user who wants to transition existing AutoCAD knowledge to MicroStation skills, this course demonstrates how MicroStation handles familiar AutoCAD operations and gives parallel references.

Subjects covered include
- setting up a new design file
- incorporating existing data from non-MicroStation CAD products
- plotting and other output considerations, including PDF creation

**Key Concepts and Tools**

Regardless of whether you are ready to pursue training, the exercises in this guide hopefully have made you curious enough to want to continue to explore MicroStation on your own.

In the sections that follow, key concepts and tools to which you should direct your attention are identified. You will learn where to find these “gems” among MicroStation’s many toolboxes, menus, and dialogs. In each case we identify relevant topics in the MicroStation help document and provide navigation paths to those topics. (For brevity reference topics for individual dialogs are not listed; to get help while you use a particular dialog, press <F1>.)
Design plane and working units

During the exercises you placed, manipulated, and modified elements *in* a view window. But what were you drawing *on*?

The MicroStation equivalent of a sheet of drafting paper is the design plane. Unlike a sheet of drafting paper, however, the design plane is extremely large, letting you draw your models at full scale. Working units are real-world units to which the design plane is configured.

Creating a model without consideration for units is not really modeling at all but merely drawing. Make sure you define the working units in a newly created design file before you place any elements.

In MicroStation

- Design File Settings dialog (*Settings > Design File*), Working Units category

Design plane and working units help topics:

- Getting Started > Fundamentals > Preparing to Draw
Levels

In the exercises you were introduced to the concept of levels and the active level. Their importance cannot be understated. Levels are the primary means of imposing order in models created using MicroStation. Recall that the display of elements residing on particular levels can be turned on and off so you can see only the information you want to see.

In MicroStation

• Active Level control in the Attributes toolbox, which is docked to the top of the application window by default

• Level Manager dialog (click the Level Manager icon in the Primary Tools toolbox, which is docked to the top of the application window by default)

• Level Display dialog (click the Level Display icon in the Primary Tools toolbox)

Levels help topics

• Getting Started > Levels

• Setting Up Projects > The Level System
Seed files and DGN libraries

If you are thinking that setting up working units and a level structure for a design project are not tasks for MicroStation novices, you are correct. MicroStation provides two mechanisms that enable administrators to set up and share working units, level structures, and other design file settings and resources — seed files and DGN libraries.

- A new design file is created by copying an existing seed file, which serves as a template. A seed file contains preset values such as initial element parameters, dimensionality (2D or 3D), working units settings, and perhaps some initial design elements. An example of the latter would be a seed file containing your company’s sheet border and title block.

Your CAD manager or project leader probably has customized seed files for your use. This will make it easier for you to adhere to required project parameters.

- A DGN library is a file used to store shared resources such as levels, cells, and text styles. It is itself a design file but with the extension .dgnlib instead of .dgn. Here again your CAD manager of project leader probably has customized DGN libraries for your use and will tell you how to configure MicroStation to use the resources they contain.

In MicroStation

- New dialog (*File > New*), Seed field and adjacent Browse button

- Dialogs used to create and maintain resources typically stored in DGN libraries. Most of these dialogs are opened from the *Element* menu.
• Configuration dialog (Workspace > Configuration), Primary Search Paths and Seed Files categories

Seed files and DGN libraries help topics:

• Getting Started > Fundamentals > Working with DGN Files
• Getting Started > Fundamentals > Models > Creating Models
• Setting Up Projects > Workspaces > Workspace Configuration > Seed Files Configuration Variables
• Setting Up Projects > Building DGN Libraries
• Setting Up Projects > Workspaces > Workspace Configuration > Primary Search Paths Configuration Variables
Workspaces

A workspace is a custom MicroStation configuration that is set up by an administrator. By selecting a workspace, you customize MicroStation for a specific discipline, project, or task.

MicroStation is delivered with a sample workspace containing example files, which show many MicroStation features. When a workspace is active, the files and tools you need to perform specific design work are available. Tools that are not necessary are removed from the interface.

In MicroStation

- File Open dialog (File > Close)

- About Workspace window (Workspace > About Workspace)

- Preferences dialog (Workspace > Preferences)
- Configuration dialog (Workspace > Configuration)
- Customize dialog (Workspace > Customize)

Workspaces help topics

- Setting Up Projects > Workspaces > Workspace Fundamentals
- Setting Up Projects > Workspaces > Workspace Configuration
- Setting Up Projects > Workspaces > Customizing the User Interface
- Getting Started > Fundamentals > User Preferences
AccuDraw

AccuDraw is the most sophisticated precision drawing aid in MicroStation. It helps you produce complex geometry quickly.

AccuDraw evaluates the current pointer location, the previously entered data point, the last coordinate directive, the currently selected tool’s needs, and any directive entered via shortcut key-ins or AccuDraw options. AccuDraw then generates the appropriate precision coordinates and applies them to the selected tool.

AccuDraw is active by default. You may have noticed the AccuDraw compass during the exercises. However, you did not actually use AccuDraw.

The compass is one of AccuDraw’s two components. The other is the AccuDraw window.

In MicroStation

- AccuDraw window (docked by default to the bottom of the application window)

AccuDraw window and the AccuDraw compass in rectangular mode

- AccuDraw Settings dialog (Settings > AccuDraw)

AccuDraw help topics:

- AccuSnap and AccuDraw > Working with AccuDraw
Snap modes

During the exercises you made frequent use of AccuSnap to snap data points to elements. The Keypoint snap mode was active, which enabled you to snap to key points on elements like the ends of a line or the center of a circle.

While Keypoint snap mode is the most frequently used snap mode, there are others; Nearest, Midpoint, Center, Origin, Bisector, and Intersection.

For example, Origin snap mode is used to snap to the origin of an element, which is the location of the first data point entered when the element was placed. Think about the names of the other modes and you probably will understand why each exists.

In MicroStation

- Snap mode icon in the status bar
- Snap Mode button bar (click the snap mode icon and select Button Bar from the pop-up menu)
- AccuSnap Settings dialog (Settings > Snaps > AccuSnap)

Snap modes help topics:

- AccuSnap and AccuDraw > Using AccuSnap > AccuSnap and Snap Mode Settings
Hatching and patterning

In models it is sometimes necessary to designate specific areas, identify components, or denote elevations. You can use the patterning and hatching tools for this.

- Patterning adds material and texture to a closed area to help express a role or function. For example, architectural wall sections might show insulation or concrete, while areas on maps may show marshes or woods.
- Hatching is simpler — it is the repetitive placement of lines in a closed area at a specific angle and spacing.

There are two types of sources for patterns:
- cells in a DGN library or cell library
- AutoCAD pattern files

The Pattern Area tool tiles the selected source pattern in the identified closed area.

In MicroStation

- Patterning toolbox

Hatching and patterning help topics:

- Creating Drawing Elements > Using Cells > Hatching and Patterning
Measuring and dimensioning

The Measuring tools in MicroStation enable you to measure distance, area, length, radius, and angle. Measurements are given in the model’s working units.

Measuring is useful as a drawing aid and for checking the integrity of a model.

While measuring tools provide you, the modeler, with information, dimensioning tools show measurement information to viewers of the model as annotations called, appropriately enough, dimensions.

If your project leader or CAD manager has defined dimension styles in a DGN library, you will be able to easily place dimensions in a consistent manner.

In MicroStation

• Measure toolbox
• Dimensions toolbox

• Dimension Styles dialog (Element > Dimension Styles)

Measuring and dimensioning help topics:

• Creating Drawing Elements > Drawing Aids > Measure toolbox
• Composing Designs > Dimensioning
Element templates

An element template is a named set of element properties. Setting the active element template changes the active element attribute settings to the properties defined in the template.

Once an administrator defines element templates in a shared DGN library, you can apply them to existing elements or use them to create elements.

Optionally you can link the active template to elements as they are placed so that if the template definition is subsequently changed, the elements’ attributes will automatically update to reflect the new definition.

In MicroStation

- Active Element Template control in the Attributes toolbox, which is docked by default to the top of the application window
- Element Templates dialog (Element > Element Templates)

Element templates help topics:

- Creating Drawing Elements > Setting the Active Element Attributes > Other Element Attributes > Element template
- Setting Up Projects > Building DGN Libraries > Element Templates in DGN Libraries
References

A reference is a model that is displayed with the active model as a background or part of a drawing composition. References let you look at the information they contain, but you can not modify them. What they do allow you is to snap to or copy their elements.

The process of associating and displaying a reference with the active model is known as attaching the reference. You can attach as many references as you need.

In MicroStation

- References dialog (click the References icon in the Primary Tools toolbox, which is docked by default to the top of the application window)

References help topics:

- Getting Started > References
- Managing References and Raster Images > Attaching References
- Managing References and Raster Images > Working with Attached References
**Saved views**

A saved view is a named view definition saved in a DGN file for later recall or for attaching to another model as a reference. The process of recalling a saved view and displaying it in a view window is known as attaching the saved view.

**In MicroStation**

- Saved Views dialog (click the Saved Views icon in the Primary Tools toolbox, which is docked by default to the top of the application window)

**Saved views help topics:**

- Getting Started > Viewing Designs > Using Saved Views
Composing drawings

Although references and saved views are useful tools for drawing and collaboration, they play an even more prominent role in the drawing composition workflow.

Assuming the models in your design are not 3D models, the drawing composition workflow is as follows:

1. Create saved views of the models.
2. Create a Drawing model and attach the saved views to it as references.
3. Derive Sheet models, each of which contains a finished drawing sheet ready for publication, from the Drawing model.

With 3D modeling, the workflow is more complicated due to the need to produce elevation and section views. This requires the preliminary step of creating a design composition, a collection of references at full scale (1:1). You can create dynamic views to automate many of the steps.

In MicroStation

- Drawing Composition workflow and its component tool groupings, which are called tasks (in the Tasks dialog which is docked by default to the left edge of the application window, click the Drawing Composition tab)
• Saved Views dialog
• References dialog
• Clip Volume toolbox (the Apply Clip Volume tool is accessible from the Create Views task, a component of the Drawing Composition workflow)
• Detailing Symbols toolbox (accessible from the Annotate task, a component of the Drawing Composition workflow)
• Define Sheet Boundary tool (accessible from the Sheet Composition task, a component of the Drawing Composition workflow)
• Create Dynamic View dialog (turn on Create Dynamic View in tool settings for detailing symbol tools, the Create Saved View tool, or the Apply Clip Volume tool)

Composing drawings help topics:
• Composing Drawings > Drawing Composition Workflow
• Managing References and Raster Images > Attaching References > Attaching References Using Views and Named Fences
• Setting Up Projects > Creating Sheet Models for Drawing Production
Link sets

Link sets make it easier to manage and access the components of a complicated design project.

A link set consists of links to design files, models, references, and saved views. You can also create links to supporting documentation such as Microsoft Word documents, Microsoft Excel spreadsheets, and PDFs. Within a link set, links can be organized into a hierarchy of folders.

Link sets are ordinarily stored in DGN libraries so they can be shared among groups of collaborators.

The Project Explorer dialog is used to navigate link sets.

In MicroStation

- Project Explorer dialog (File > Project Explorer)

- Link Sets dialog (click the Link Set icon in the Project Explorer dialog)

Link sets help topics:

Setting Up Projects > Link Sets
3D modeling and visualization

Once you master 2D modeling in MicroStation, you may want to learn 3D modeling. These are the primary benefits of working in 3D:

• You can more easily generate drawings that illustrate plans, elevations, sections, and details.

• You can use visualization tools to produce realistic color images of your designs, even animated sequences. These types of presentations are often not only more impressive to clients than traditional mock-ups and artist’s drawings but more cost-effective as well, particularly where there are frequent revisions.

The 3D tool set in MicroStation include surface modeling, mesh modeling, and solids modeling tools. Among the latter are Feature Modeling tools that let you create parametric feature-based solids.

In MicroStation

Open a 3D sample design file such as 3D-Surfaces.dgn. The file will open with the model named Index active. Then activate one of the other models.

At that point you will be able to select:

• 3D tools — these tools are grouped in the following tasks, each of which you can access by clicking their tab in the Tasks dialog. The Tasks dialog is docked by default to the left edge of the application window.
  • Solids Modeling
  • Surface Modeling
  • Mesh Modeling
  • Feature Modeling
  • Visualization
  • Animation

• Additional view controls, specific to 3D modeling, in the view control bar. These view controls include Walk, Fly, Navigate View, and Change View Perspective.

3D modeling and visualization help topics:

• 3D Design and Modeling > Understanding 3D
• Working With Complete Designs > Visualization
**Design history**

The ability to track and view incremental changes to models and to restore a model to a prior state can be quite useful in managing the design process. MicroStation provides a revision control system for these purposes called design history.

Changes can be tracked down to the element level. You can restore elements to a prior state through a combination of undoing and redoing historic changes.

**In MicroStation**

- Design History toolbox (Tools > Change Tracking > Design History > Open as Toolbox)

- Utilities > Design History submenu

**Design history help topics:**

- Setting Up Projects > Design History
**ProjectWise**

ProjectWise is an engineering project team collaboration system. Although ProjectWise is a separate product, you should be aware of it as it is tightly integrated with MicroStation and it helps teams improve quality, increase productivity, reduce rework, and meet project deadlines.

An entry-level collaboration tool named ProjectWise StartPoint is also available. It is based on Microsoft Office SharePoint technologies and designed for small teams, working on small projects. The ProjectWise StartPoint client software is delivered with MicroStation. The help document is PWStartPoint.chm and it is installed in the ..\Bentley\Documentation folder.

**ProjectWise product information on the Web:**

- ProjectWise Project Team Collaboration Products home page  
  http://www.bentley.com/ProjectWise
- ProjectWise StartPoint product home page  
Index

Numerics
3D modeling 69
3D-Surfaces.dgn 69

A
AccuDraw 29, 59
AccuSnap 10, 60
active
angle 44
color 21
element priority 21
element template 63
element transparency 21
fill color 21
fill type 21
level 21, 55
line style 21
line weight 21
scale 39
active angle 46
Adobe Reader 30
angle 44, 46
measuring 62
animating 69
annotating 45, 62, 67
application window 3
area
crosshatching 61
hatching 61
measuring 62
patterning 61
attaching
references 64
saved views 65
views 65
attributes
elements. See element attributes
text. See also text 45
text. See text toolbox 21
view 26
AutoCAD 53

B
Bentley Institute 51
learning path 52
MicroStation Essentials 52
MicroStation for AutoCAD Users 53
bisector snap 60
blocks 18
corner 34
snapping to corner 34
boundaries 67

C
cells
active 44
for patternning 61
pattern 61
center snap 60
change tracking 70
circles 9
center 32
snapping to center 32
clip volumes 67
configuration variables 26
collaboration 64, 71
color 21
active 21
fil 21
context-sensitive help 15
contextual menus 5
preferences 6
copying
elements 33
creating
design files 2, 56
crosshatching 61
cross-sections 66

data points 10
locked to grid 27
snapping 10
default tool 17
deleting
elements 41
parts of elements 41
design files 2
3D-Surfaces.dgn 69
creating 2, 56
elements 58
Learning.dgn 32, 43
new 2, 56
opening 2, 58
sample 58
saving 14
seed 56
settings 26, 54
design history 70
design plane 54
detailing symbols 67
details 69
DGN files. See design files
libraries. See DGN libraries
DGN libraries 56, 62, 63, 68
dialogs
About Workspace window 58
AccuDraw Settings 59
AccuDraw window 59
AccuSnap Settings 60
Configuration 57, 58
Create Dynamic Views 67
Customize 58
Design File Settings 54
Design History 70
Element Templates 63
File Open 2, 58
Level Display 55
Level Manager 55
menu bars in 5
New 56
preferences 6
Print 29
Project Explorer 68
References 64
Save Print As 30
Saved Views 65
Select Printer Driver
Configuration File 30
Snap Mode button bar 60
dialogs (continued)
   Tasks 66, 69
   Text Editor window 46
tool settings window 20, 24
View Groups 4
dimensioning 26, 62
dimensions 26, 62
distance
   measuring 62
drawings 68
drawing aids
   AccuDraw 29, 59
dimensioning 26
   styles 62
text. See text
   editing 58
text. See text
   elevations 66, 69
example files 58

deleting 33
deleting 39
dimensioning 26, 62
dimensions 26, 62
distance
   measuring 62
drawings 68
drawing aids
   AccuDraw 29, 59
dimensioning 26
   styles 62
text. See text
   editing 58
text. See text
   elevations 66, 69
example files 58

dimensioning 26
   styles 62
dimensions 26, 62
distance
   measuring 62
drawings 68
drawing aids
   AccuDraw 29, 59
dimensioning 26
   styles 62
text. See text
   editing 58
text. See text
   elevations 66, 69
example files 58

dimensioning 26
   styles 62
dimensions 26, 62
distance
   measuring 62
drawings 68
drawing aids
   AccuDraw 29, 59
dimensioning 26
   styles 62
text. See text
   editing 58
text. See text
   elevations 66, 69
example files 58

dimensioning 26
   styles 62
dimensions 26, 62
distance
   measuring 62
drawings 68
drawing aids
   AccuDraw 29, 59
dimensioning 26
   styles 62
text. See text
   editing 58
text. See text
   elevations 66, 69
example files 58

dimensioning 26
   styles 62
dimensions 26, 62
distance
   measuring 62
drawings 68
drawing aids
   AccuDraw 29, 59
dimensioning 26
   styles 62
text. See text
   editing 58
text. See text
   elevations 66, 69
example files 58
**Index**

**N**
- nearest snap 60

**O**
- online help. See help opening design files 2, 58
- origin snap 60
- output 29

**P**
- panning 13
- paths
  - search 57
  - patterning 61
- PDFs 29, 68
- printer driver 30
- perspective 69
- Place Active Cell tool 44
- Place Block tool 18
- Place SmartLine tool 10
- settings 20
- placing
  - arcs 24
  - blocks 18
  - circles 9
  - elements 9
  - lines 10
  - rectangles 18
  - shapes 18
  - squares 18
- text 46
- plans 69
- plotter 29
- plotting 29
- precision input
  - AccuDraw 29, 59
- snapping 10
- preferences 26
  - automatically save settings 14
  - Reset Pop-up Menu 6
  - press and hold 6
- primary search paths 57
- Primary Tools toolbox 32, 64, 65

**R**
- radius
  - measuring 62
- read-only 64
- rectangles 18
- redo 70
- references 64, 66
  - attaching 64
  - rendering 69
- reset 19
  - button 6
  - pop-up menus. See contextual menus
- revision control 70
  - right-click menus. See contextual menus
- rotating
  - elements 35

**S**
- sample files 58
- saved views 65, 66
  - creating 67
- saving
  - design file 14
  - settings 14
  - views. See saved views
- scale
  - active 39
  - full 66
  - print 29
- scaling
  - elements 38
- search paths 57
- sections 66, 69
- seed files 56
- selecting
  - elements 34, 35, 38
  - tools 23
- settings
  - active color 21
  - active element
    - attributes 21, 23
    - active element priority 21
    - active element transparency 21
  - active fill color 21
  - active fill type 21
  - active level 21
  - active line style 21
  - active line weight 21
  - configuration variables 26
- design file 26
- dimension attribute 26
- element attributes 21, 23
- grid display 26
- Grid Lock 27
- preferences.
  - See preferences
- saving 14
- templates 63
- text attribute 26
- tool 20, 24
- units 26
- user preferences. See preferences
- working units 26
- Settings menu
  - AccuDraw 59
  - Design File 54
  - Snaps > AccuSnap 60
- shapes 18
- SharePoint 71
- sheets 66
- boundary 67
- SmartLine 10
  - see also lines
- snapping 10
  - modes 60
  - to center of circle 32
  - to corner of blocks 34
  - to vertices 40
- solids modeling 69
- spreadsheets 68
- squares 18
- starting 1
- StartPoint 71
- status bar 24, 60
- surface modeling 69
- symbols
  - detailing 67

**T**
- tasks 66
  - Annotate 67
  - Create Views 67
  - Drawing Composition (workflow) 66
  - Sheet Composition 67
- templates
  - element 63
- text 26, 45
  - above 47
  - attributes 45
  - editing 46
  - fitting 48
  - font 45
  - height 46
  - justification 45
  - origin 46
  - placing 46
  - styles 46
  - width 46
- toolboxes 23
  - Attributes 21, 55, 63
  - Clip Volume 67
  - Design History 70
  - Detailing Symbols 67
  - Dimensions 62
  - Main 32
  - Manipulate 32
  - Measure 62
Index

toolboxes (continued)
  Modify 40
  Patterning 61
  Primary Tools 32, 64, 65
tools 7
  Apply Clip Volume 67
  collaboration 71
  Copy 33, 34
  Create Saved View 67
  default tool 17
  Define Sheet Boundary 67
  Delete Element 41
  Delete Part of Element 41
  Element Selection 34, 35, 38
  feature modeling 69
  grouped in tasks 66
  interrupting operation 17
  mesh modeling 69
  Modify Element 39
  Move 32
  Partial Delete 41
  Pattern Area 61
  Place Active Cell 44
  Place Block 17, 20
  Place SmartLine 20
  Place Text 46
  resuming operation 17
  Rotate 35
  Scale 38
  selecting 23
  settings 20, 24
  solids modeling 69
  surface modeling 69
  tracking selection 15
Tools menu 23
  Change Tracking > Design History 70
  tracking 15
  training 51
  transparency 21

U
  undo 5, 13, 70
  units 26, 54
  user preferences. See user preferences
  Utilities menu
    Design History 70

V
  vertices
    snapping to 40
  view controls 12
    Change View Perspective 69
    Fly (3D) 69
    interrupting tools to use 17
    Navigate View (3D) 69
    undo 13
    Walk (3D) 69
    Window Area 18
  view windows. See views
  views
    attaching saved 65
    attributes 26
    closing 4
    controls. See view controls
    creating 67
    elevation 66
    fitting 13
    flying in (3D) 69
    grid display in 26
    navigating (3D) 69
    next 13
    opening 4
    panning 13
    perspective (3D) 69
    previous 13
    recalling 65
  section 66
  saved. See saved views
  walking in (3D) 69
  windowing area 18
  visualizing 69
  volumes
    clip 67

W
  Window Area 18
  windows
    About Workspace 58
    AccuDraw 59
    Microsoft. See Microsoft Windows
    Text Editor 46
    tool settings 20
  view. See views
  workflows
    Drawing Composition 66
    working units 26, 54
  Workspace menu
    About Workspace 58
    Configuration 57, 58
    Customize 58
    Preferences 6, 58
    workspaces 58

Z
  zooming 12